0

I am trying to kill the redis-server process on macOS. Whenever I kill it or shut it down, it restarts under a different process id.

I've tried killing it three ways:

  1. redis-cli shutdown
  2. sudo kill [proc-id] : It's running as root for whatever reason, so sudo is needed.
  3. brew services stop redis

I checked ~/Library/LaunchAgents/ and /System/Library/LaunchAgents/ for an applicable plist but none of the files contain redis, case insensitive search.

I also checked the "Users & Groups" section of the macOS control panel and do not see any entries under "Login Items" that are applicable.

The macOS console app reveals something interesting when I kill the process:

com.apple.xpc.launchd[1] (org.redis.redis-server): Service only ran for 8 seconds. Pushing respawn out by 2 seconds`

So it seems that it's registered and being watchdogged by launchd, but I can't figure out where the configuration is for the life of me.

launchctl list|grep -i redis does not reveal any results, either.

Thoughts?

YWCA Hello
  • 203
  • 1
  • 2
  • 9
  • If it's running as root, it's a launch daemon not a launch agent, which means you need to use `sudo launchctl` to control it. Try `sudo launchctl list org.redis.redis-server` and `sudo launchctl disable org.redis.redis-server` – Gordon Davisson Aug 02 '17 at 05:44
  • 1
    @GordonDavisson `list` revealed a result. Running `sudo launchctl disable system/org.redis.redis-server` and `sudo launchctl stop org.redis.redis-server` seems like it should have worked, but the process is still running and it still restarts after killing it. – YWCA Hello Aug 02 '17 at 15:41
  • 1
    @GordonDavisson same issue sudo launchctl disable org.redis.redis-server returns unrecognized target specifier.. error – SudarP Jun 16 '18 at 00:13

0 Answers0