0

I setup a port channel between two Cisco switches, a 6509 running ios 12.2(17r)S4 and a 5596 running nx-os 5.2(1)N1(4). Several issues arose including bad patches and broken cables, but I currently have two active links in the port channel to work with. The issue is that people on that leg are seeing sporadic connectivity issues.

On ios, I am seeing the following etherchannel status, which implies each link is not acting as a single channel, but instead on it's own independent group:

coresw02#show etherchannel 4 detail     
Group state = L2 
Ports: 3   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
Minimum Links: 0
        Ports in the group:
        -------------------
Port: Gi4/9
------------

Port state    = Up Sngl-port-Bndl Mstr Not-in-Bndl 
Channel group = 4           Mode = Active      Gcchange = -
Port-channel  = null        GC   =   -         Pseudo port-channel = Po4
Port index    = 0           Load = 0x00        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi4/9     SA      indep     32768         0x4       0x4     0x40A       0x7D  

Age of the port in the current state: 0d:06h:55m:38s

Port: Gi4/25
------------

Port state    = Down Not-in-Bndl 
Channel group = 4           Mode = Active      Gcchange = -
Port-channel  = null        GC   =   -         Pseudo port-channel = Po4
Port index    = 0           Load = 0x00        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi4/25    FA      down      32768         0x4       0x4     0x41A       0x47  

Age of the port in the current state: 0d:06h:29m:28s

Port: Gi4/27
------------

Port state    = Up Sngl-port-Bndl Mstr Not-in-Bndl 
Channel group = 4           Mode = Active      Gcchange = -
Port-channel  = null        GC   =   -         Pseudo port-channel = Po4
Port index    = 0           Load = 0x00        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi4/27    SA      indep     32768         0x4       0x4     0x41C       0x7D  

Age of the port in the current state: 0d:06h:44m:28s

        Port-channels in the group: 
        ----------------------

Port-channel: Po4    (Primary Aggregator)

------------

Age of the Port-channel   = 4d:03h:19m:57s
Logical slot/port   = 14/2          Number of ports = 0
HotStandBy port = null 
Port state          = Port-channel Ag-Not-Inuse 
Protocol            =   LACP
Fast-switchover     = disabled
Load share deferral = disabled   


Last applied Hash Distribution Algorithm:   -

Additionally, even though the above outpush shows the links are up, checking the status of the portchannel interface shows it as down:

coresw02#show interface port-channel 4
Port-channel4 is down, line protocol is down (notconnect)
  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
  Description: CHANNEL TO 10G
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, media type is unknown
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
coresw02#show etherchannel 4 detail   
Group state = L2 
Ports: 3   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
Minimum Links: 0

This would make sense if every link were broken, but we know two of them are good and we do have traffic flowing over this port channel, so I am at a loss as to how it believes itself to be down or the cause of our connectivity issues.

relevant ios config:

interface Port-channel4
 description CHANNEL TO 10G
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 103,211,645,647
 switch   port mode trunk
!
interface GigabitEthernet4/9
 description UPLINK D22/5
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 103,211,645,647
 switchport mode trunk
 channel-protocol lacp
 channel-group 4 mode active
!
qinterface GigabitEthernet4/25
 description UPLINK D22/15 (D22/13 dead)
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 103,211,645,647
 switchport mode trunk
 channel-protocol lacp
 channel-group 4 mode active
!
interface GigabitEthernet4/27
 description UPLINK D22/14
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 103,211,645,647
 switchport mode trunk
 channel-protocol lacp
 channel-group 4 mode active
!

nx-os config:

interface port-channel6
  description CORE-SWITCH-UPLINK
  switchport mode trunk
  switchport trunk allowed vlan 103,211,645,647
!
interface Ethernet4/13
  description CORE-SWITCH-UPLINK
  switchport mode trunk
  switchport trunk allowed vlan 103,211,645,647
  speed 1000
  channel-group 6

interface Ethernet4/14
  description CORE-SWITCH-UPLINK
  switchport mode trunk
  switchport trunk allowed vlan 103,211,645,647
  speed 1000
  channel-group 6
!
interface Ethernet4/15
  description CORE-SWITCH-UPLINK
  switchport mode trunk
  switchport trunk allowed vlan 103,211,645,647
  speed 1000
  channel-group 6
!
interface Ethernet4/16
  description CORE-SWITCH-UPLINK
  switchport mode trunk
  switchport trunk allowed vlan 103,211,645,647
  speed 1000
  channel-group 6

You will see we have more interfaces configured than we have up, this is due to the aforementioned issues. One cable was causing corrupt traffic so we unplugged it after it had been configured, the other cable never was configured on the ios side since the patch was dead.

I will continue updating as I debug further.

fishpen0
  • 113
  • 2
  • 8

1 Answers1

0

It turns out that Sngl-port-Bndl Mstr Not-in-Bndl is indicative of an improperly configured port channel where each individual link has established its own individual connection. In the case of this exact scenario, the 5596 running nx-os 5.2(1)N1(4) was not configured to do LACP. By default, nx-os apparently does not set a protocol. We resolved this issue by reconfiguring the 5596 to use lacp.

fishpen0
  • 113
  • 2
  • 8