-1

I am using two routers and one host (computer), I connected fast Ethernet 0/1 of router A with the host and fa0/0 of the router A with the router B I have configured gateway as last resort on both routers, I tried to ping host with router B and it was successful, therefore the path is fine. I configured NAT translation on router A, I pinged the host with router again and it was successful and thereafter I typed "show ip nat translation" and I ended up with no output. Why is that?

This is the output of the "show ip nat statistics" of router A

Router#sh ip nat stat
Router#sh ip nat statistics 
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: FastEthernet0/0
Inside Interfaces: FastEthernet0/1
Hits: 0  Misses: 22
Expired translations: 0
Dynamic mappings:
-- Inside Source
access-list 10 pool todd refCount 0
pool todd: netmask 255.0.0.0
   start 50.0.0.1 end 50.0.0.1
   type generic, total addresses 1 , allocated 0 (0%), misses 0

output of show run on router A Router#sh run Building configuration...

Current configuration : 822 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.2.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat pool todd 50.0.0.1 50.0.0.1 netmask 255.0.0.0
ip nat inside source list 10 pool todd overload
ip classless
ip default-network 10.0.0.0
ip route 10.0.0.0 255.0.0.0 10.1.1.2  
!
ip flow-export version 9
!
!
access-list 10 permit 0.0.0.0 255.255.255.0
!
no cdp run 
!
!
!

output of show run of router B

Router#sh run
Building configuration...

Current configuration : 651 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.0.0.0
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 
!
ip flow-export version 9
!
!
!
!
!
Konrad Gajewski
  • 1,518
  • 3
  • 15
  • 29

1 Answers1

1

On router A, your acess-list 10 seems to be wrong

access-list 10 permit 0.0.0.0 255.255.255.0

do this

config t

no access-list 10

access-list 10 permit 10.1.2.0 0.0.0.255

Abu Zaid
  • 499
  • 2
  • 6