1

I've installed OpenIndiana 151a7 twice now. Configured a static ip using the following instructions:

svcadm disable svc:/network/physical:nwam
svcadm enable svc:/network/physical:default
cp /etc/nsswitch.dns /etc/nsswitch.conf

/etc/nodename

storage

/etc/hostname.e1000g0

10.0.1.64 netmask 255.255.248.0

/etc/resolv.conf

search lbox.com
nameserver 10.0.1.45
nameserver 10.0.1.46

/etc/inet/hosts

127.0.0.1 storage storage.local localhost loghost
10.0.1.64 storage storage.lbox.com

/etc/inet/ipnodes

127.0.0.1 storage storage.local localhost loghost
10.0.1.64 storage storage.lbox.com

/etc/defaultdomain

/etc/defaultrouter

10.0.1.2

reboot

I cannot ping and cannot for the life of me figure out why.

I also tried this alternative:

/etc/hostname.e1000g0

10.0.1.64

/etc/netmasks

10.0.1.0    255.255.248.0

Can anyone help me figure out why I can't ping?

David Vasandani
  • 256
  • 3
  • 13
  • 1
    You could start by providing error messages and a description of what happens when you try to ping. – Michael Hampton Mar 20 '13 at 11:39
  • 1
    It's actually a little annoying... I hated this process in OpenSolaris. The key is `svcadm disable svc:/network/physical:nwam` – ewwhite Mar 20 '13 at 16:36

2 Answers2

4

I used the ipadm command. Process documented here http://docs.oracle.com/cd/E19963-01/html/821-1458/gjwiq.html

colechristensen
  • 602
  • 1
  • 5
  • 14
1

I let the OpenIndiana install find its DHCP address and then followed this format

echo 192.168.1.1 > /etc/defaultrouter
svcadm disable svc:/network/physical:nwam
svcadm enable svc:/network/physical:default
cp /etc/nsswitch.dns /etc/nsswitch.conf
echo storage > /etc/nodename
echo 10.0.1.64 > /etc/hostname.e1000g0

vim /etc/resolv.conf
    search lbox.com
    nameserver 10.0.1.45
    nameserver 10.0.1.46

vim /etc/inet/ipnodes
    127.0.0.1 storage storage.local localhost loghost
    10.0.1.64 storage storage.lbox.com

echo 10.0.1.2 > /etc/defaultrouter
echo 10.0.1.64 > /etc/hostname.e1000g0
echo 10.0.1.0 255.255.248.0 > /etc/netmasks

reboot

And everything worked.

EDIT: no it didn't

David Vasandani
  • 256
  • 3
  • 13