Questions tagged [http-proxy]
123 questions
19
votes
3 answers
SSH over HTTPS with proxytunnel and nginx
I'm trying to setup an ssh over https connection using nginx. I haven't found any working examples, so any help would be appreciated!
~$ cat .ssh/config
Host example.net
Hostname example.net
ProtocolKeepAlives 30
DynamicForward 8118
…

Thermionix
- 917
- 2
- 15
- 28
13
votes
5 answers
What is a good SQUID Logs Analyzer?
Can anyone recommend me a good tool for analyzing squid logs ?
I'm currently using SARG. Is there something better?
I need to easily see what sites were visited/denied, when and by whom.
There is a list of squid analyzers. Some of them seem to be…

Jindrich
- 4,968
- 8
- 30
- 42
11
votes
2 answers
Docker daemon answers '404 page not found' after update
I recently updated my docker from 1.4 to 1.5 (with the package lxc_docker).
Since then, docker daemon sends an error like this (for every command):
$ docker version
Client version: 1.5.0
Client API version: 1.17
Go version (client): go1.4.1
Git…

aveuiller
- 245
- 1
- 5
- 8
8
votes
2 answers
How can I redirect URLs using the proxy module in Apache?
This seems like a super-basic question but I am having a hard time tracking down a straightforward solution, so appreciate any help and patience with me on this:
I want to configure my Apache proxy server to redirect certain URLs so that, for…
LearningIT
7
votes
2 answers
Looking for a lightweight NTLM HTTP proxy server
For some testing, I am looking for an NTLM HTTP proxy server. The server should authenticate the clients, not delegate that authentication to an upstream "real" NTLM proxy server (like "NTLMAPS" or "CNTLM" does).
What is the easiest way to create an…

Rich
- 704
- 14
- 30
7
votes
3 answers
What's the easiest way to create an HTTP proxy which adds basic authentication to requests?
I am trying to use a service provided by a server which requires basic HTTP authentication, however the application I am using does not support authentication. What I'd like to do is create a proxy that will enable my auth-less application to…

joshdoe
- 173
- 1
- 1
- 3
6
votes
1 answer
how to fix apache2 "proxy_http:error" AH01102: error reading status line from remote server localhost:4382
how to fix apache2 "proxy_http:error" AH01102: error reading status line from remote server localhost:4382.
I have an apache2 webserver which is being used to serve few nodejs applications in the backend.
Apache2 webserver version:
Server…

devops-admin-jacky
- 61
- 1
- 1
- 3
5
votes
6 answers
For a small home network, is there any point to running Squid?
For a small home network -- two laptops, two desktops, plus the main server -- should I expect much gain by running Squid on the main server? I fully understand the value of running a caching name server for a small home network, but I'm not sure…

Eddie
- 11,432
- 8
- 37
- 48
5
votes
3 answers
How do I set up RouterOS to use web proxy on another machine?
The RouterOS docs show how to transparently proxy all web traffic via the HTTP proxy built into RouterOS:
/ip firewall nat
add in-interface=ether1 dst-port=80 protocol=tcp action=redirect to-ports=8080 chain=dstnat
/ip proxy
set enabled=yes…

Tim
- 277
- 4
- 6
- 13
4
votes
3 answers
caching proxy server for windows 8
I need to setup a local caching proxy server on windows 8 so I can cache some web contents to both speed up page loads and prevent our low quality internet connection from letting us down every now and then.
in our country even some js & css files…

yaser
- 95
- 2
- 8
4
votes
3 answers
How to configure Squid with for authentication but skip it for local requests?
My Squid HTTP proxy works fine with authentication. Here is the config:
auth_param basic program /usr/lib/squid/pam_auth
auth_param basic children 5
auth_param basic realm test-proxy
auth_param basic credentialsttl 4 hours
auth_param basic…

Witek
- 1,433
- 3
- 14
- 16
4
votes
1 answer
Logging HTTPS traffic through a proxy
How do I configure squid (or any other) proxy server to keep log of URLs visited, and files downloaded, over HTTPS?
Is it possible?

Abhijeet Pathak
- 175
- 1
- 1
- 8
4
votes
3 answers
How can I force VM's to use the machine host proxy settings?
I have various types of VM's running that I'd like to use my local host machine's proxy settings. This way any browser activity from the VM would go through the host proxy even if the VM's proxy settings are turned off. But they seem to ignore the…

IAmAN00B
- 141
- 1
- 1
- 3
4
votes
4 answers
Set up HTTP Proxy for Tomcat Web server
Basically, I'm trying to make SOAP calls from a Tomcat server via a corporate proxy/ firewall (which I have no direct control over), I've tried to add info to the catalina.properties file as…

alimack
- 943
- 2
- 11
- 22
4
votes
1 answer
Multi-threaded alternative to tinyproxy?
Are there any free, light-weight, single-process (e.g. multi-threaded, asyncore) HTTP forward proxy software?
Tinyproxy works great, but it uses multiple processes like (Apache's) prefork. HAProxy and nginx are reverse proxies don't seem to have…

netvope
- 2,123
- 5
- 25
- 35